<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://connecticut.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="nfc north, chicago bears, green bay packers, minnesota vikings, detroit lions" />
<meta name="keywords" content="nfc north, chicago bears, green bay packers, minnesota vikings, detroit lions" />
<meta property="fb:pages" content="21164911483" />
<title>NFC North Preview: &#8216;Got To Give It Up To The Reigning MVP In Aaron Rodgers,&#8217; Says CBS Chicago&#8217;s Marshall Harris &#8211; CBS Connecticut</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.mp.lura.live' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Connecticut &raquo; Feed" href="https://connecticut.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://connecticut.cbslocal.com/_static/??-eJytj0sOwjAMRC9EcECiUheIs6SJKVEdO8pHvT4hZcMKKrGyPfYbjWGNygoX5ALlgQEz2CkrEmsIPFuq7iXlDHeRgunY2gP8BGGY0G1sTEhi3Hc4Up09ZwjiKrWNeRu0uh/uByoYNjOmbvOhqBZyKRJ3vLR51DCx8aTI8/L/VEht4tL/vYXraTiPo9aDvjwBdZWfVw==' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://connecticut.cbslocal.com/_static/??-eJyNy8EJgDAMQNGFrKmChR7EWWoMKqSxkIi4vXYB8fp5H67i8BAjMbCNMingrI4PTAxqN1OLqg18sV2Qz6UmVShpJWeUCyf78daF+I1iWvWUxy70MXof/PAAIdM5Gg==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://connecticut.cbslocal.com/_static/??-eJy1kttOwzAMhl+INB1MIC4Qz+ImVpfNOShxV+XtcTvGNiqh9oI7n77fsR09JmViYAys+YAeizZdURQNkE409C4U7aMdSDJzgfIQoMesTZFITbhvxHrSfwm5YGiwU0iY0VlUjD4RMJaNcILMK5jfLy+HmNnEq8rN3dAefYf2ws+mIldYGWCg2G8cQ6ZwhlCdb8t7yFuR1p2AJ+nSZchVF66EjXdhSRxlULQOkKSn9L53ZMsVsyLswdR1uOTu/Qdo9cblyj3yz8Une7vI8sN5yKdJ9lJvIsX8D7rxjHnMjnEh7Qd1FTsiJ5AD7dqmnTW+AxPz6T92ry9t+75/fmu/AKYsRdQ=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://connecticut.cbslocal.com/_static/??-eJy1UEEOwjAM+xBdxiQm7YB4S+m60ZKmZUlB+z1l4sBuA4mTFcd2rMAjKRNJLAnIxQbLYM6sMBqN4Mhg7gvlGVLEeXCIVXBUed7BVqPf5EiYR0cMIfYZy0b3i7mAujefCavoW7bT/IZNIhXcOGmxP3VaBCpo0qOdXtErQpV7V4npq+cMmYy4SPyPQhbLRMIl9xSO+7bpurpu64N/ArDmujg='></script>
<script src='https://w3.mp.lura.live/player/prod/v3/scripts/anvload.js?ver=5.8' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://connecticut.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILQWJSTsgvqVLoy5V2k4kZb+/CnHhwm6W/WzDvg1Yi1ExsJUyKeCig1T0AlxQWuhWUvBhJeU3jZnLmPQC/4qdj1IXL6fkz8XLGIVOO5u0yEUh19CkJzuHSPaZ+Mo+8cyP63SbZ+cmd08HCshU0A=='></script>
<link rel="https://api.w.org/" href="https://connecticut.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://connecticut.cbslocal.com/wp-json/wp/v2/posts/357305" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://connecticut.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://connecticut.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8" />
<link rel='shortlink' href='https://cbsloc.al/3zIlU0e' />
<link rel="alternate" type="application/json+oembed" href="https://connecticut.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fconnecticut.cbslocal.com%2F2021%2F09%2F02%2Fnfc-north-preview-packers-bears-vikings-lions%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://connecticut.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fconnecticut.cbslocal.com%2F2021%2F09%2F02%2Fnfc-north-preview-packers-bears-vikings-lions%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		
<meta property="og:title" content="NFC North Preview: &#039;Got To Give It Up To The Reigning MVP In Aaron Rodgers,&#039; Says CBS Chicago&#039;s Marshall Harris" /><meta property="og:image" content="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/09/aaron-rodgers-packers-1.jpg?w=1200" /><meta property="og:image:secure_url" content="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/09/aaron-rodgers-packers-1.jpg?w=1200" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:description" content="The Packers still have all the pieces to make another run at a Super Bowl, especially with Rodgers under center." /><meta property="og:type" content="article" /><meta property="og:url" content="https://connecticut.cbslocal.com/2021/09/02/nfc-north-preview-packers-bears-vikings-lions/" /><meta property="article:published_time" content="2021-09-02T15:25:44+00:00" /><meta property="article:suggested-social-copy" content="The Packers still have all the pieces to make another run at a Super Bowl, especially with Rodgers under center." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Sports" /><meta property="article:publisher" content="https://www.facebook.com/CBSLocal" /><meta property="article:author" content="https://www.facebook.com/CBSLocal" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/09/aaron-rodgers-packers-1.jpg?w=1200"><meta name="twitter:title" content="NFC North Preview: &#039;Got To Give It Up To The Reigning MVP In Aaron Rodgers,&#039; Says CBS Chicago&#039;s Marshall Harris"/><meta name="twitter:description" content="The Packers still have all the pieces to make another run at a Super Bowl, especially with Rodgers under center."/><meta name="twitter:site" content="/cbslocal"/>
<link rel="canonical" href="https://chicago.cbslocal.com/2021/09/02/nfc-north-preview-packers-bears-vikings-lions/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://connecticut.cbslocal.com/2021/09/02/nfc-north-preview-packers-bears-vikings-lions/?amp">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/connecticut.cbslocal.com","url":"https:\/\/connecticut.cbslocal.com","name":"CBS Connecticut","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/connecticut.cbslocal.com\/wp-content\/uploads\/sites\/15909867\/2018\/07\/2_cbs_connecticut.png?w=284"}},"url":"https:\/\/connecticut.cbslocal.com\/2021\/09\/02\/nfc-north-preview-packers-bears-vikings-lions\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/connecticut.cbslocal.com\/2021\/09\/02\/nfc-north-preview-packers-bears-vikings-lions\/"},"headline":"NFC North Preview: &#8216;Got To Give It Up To The Reigning MVP In Aaron Rodgers,&#8217; Says CBS Chicago&#8217;s Marshall Harris","description":"The Packers still have all the pieces to make another run at a Super Bowl, especially with Rodgers under center.","image":"https:\/\/connecticut.cbslocal.com\/wp-content\/uploads\/sites\/15909867\/2021\/09\/aaron-rodgers-packers-1.jpg?w=1200","keywords":["Sports","Marshall Harris","NFC North","Norm Elrod","sports","NFC North Preview: 'Got To Give It Up To The Reigning MVP In Aaron Rodgers,' Says CBS Chicago's Marshall Harris"],"datePublished":"2021-09-02T15:25:44+00:00","dateModified":"2021-09-02T15:25:44+00:00","video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"'Snapchat Dysmorphia': Selfies, Photo Filters Driving People To Plastic Surgery, Doctors Say","description":"Plastic surgeons are sounding the alarm on a disturbing trend.","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/captures\/A0D\/A2F\/A0DA2F76BBF64829BAD50D1EE24A46F9.jpg?Expires=1725235200&KeyName=mcpkey1&Signature=dKa8u3Teg_0InqD3jdQOn7b5G3M","uploadDate":"2018-08-07","duration":"T24S","contentUrl":"https:\/\/connecticut.cbslocal.com\/video\/3912994-snapchat-dysmorphia-selfies-photo-filters-driving-people-to-plastic-surgery-doctors-say\/","embedUrl":"https:\/\/connecticut.cbslocal.com\/video\/3912994-snapchat-dysmorphia-selfies-photo-filters-driving-people-to-plastic-surgery-doctors-say\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.HARTFORD","sports",["nfcnorthpreviewgottogiveituptothereigningmvpinaaronrodgerssayscbschicagosmarshallharris","post","article","sports","marshallharris","nfcnorth","normelrod","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("3");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-64" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-64" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"sports;","dimension2":"article"});gtag("config","UA-2438645-64");</script>

		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="The Packers still have all the pieces to make another run at a Super Bowl, especially with Rodgers under center." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-357305 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://connecticut.cbslocal.com" id="header-logo"><img src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2018/07/2_cbs_connecticut.png?w=284" alt="CBS Connecticut" /></a>
	
	<nav id="navigation-main" data-item-count="6"><ul class="top"><li class="menu-top-item item-0 section-item"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="http://connecticut.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-1" class="embed-item embed-list column-count-2 block-type-wpmenu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">All News</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="/category/top-headlines/" title="Headlines" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Headlines</strong></div></a><a href="/category/national/" title="National" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">National</strong></div></a><a href="/category/world-news/" title="World" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">World</strong></div></a><a href="/category/technology" title="Technology" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Technology</strong></div></a><a href="http://connecticut.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://connecticut.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><a href="http://connecticut.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a></div>
</div></div><div id="embed-list-2" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Latest Headlines</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/2021/09/02/stimulus-check-latest-irs-fourth-relief-payment/" title="Fourth Stimulus Check: Will Another Relief Payment Go Out In 2021?" class="cbs-thumbnail-link item-1630601555" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/09/joe-biden-1-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Fourth Stimulus Check: Will Another Relief Payment Go Out In 2021?</strong><em class="description">A spike in COVID cases is still preventing the ongoing economic recovery from reaching millions of Americans, though a fourth stimulus check could help.</em></div></a><a href="https://connecticut.cbslocal.com/2021/08/25/vaccine-mandates-covid-delta-variant-fda-approval/" title="Where Do COVID Vaccine Mandates Stand?" class="cbs-thumbnail-link item-1629916887" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/covid-vaccine-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Where Do COVID Vaccine Mandates Stand?</strong><em class="description">With the FDA&#039;s full approval of Pfizer&#039;s vaccine for COVID, vaccine mandates may become more prevalent in the the public and private sector.</em></div></a></div>
</div></div><div id="embed-list-3" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Podcasts</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-4 aspect-ratio-1-1"><a href="http://connecticut.cbslocal.com/audio/mornings-with-ray-dunaway/" title="Ray Dunaway" class="cbs-thumbnail-link item-1476544755" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2016/10/ray-dunaway-250x250.jpg?w=250&#038;h=250&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Ray Dunaway</strong></div></a><a href="http://connecticut.cbslocal.com/audio/sound-off-connecticut-with-jim-vicevich/" title="Sound off Connecticut" class="cbs-thumbnail-link item-1476459631" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2016/10/sound-off-ct-250x250.jpg?w=250&#038;h=250&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Sound off Connecticut</strong></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="http://connecticut.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-4" class="embed-item embed-list column-count-2 block-type-wpmenu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="http://connecticut.cbslocal.com/category/sports/">All Sports</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="http://www.cbssports.com/mlb/teams/page/NYY/new-york-yankees" target="_blank" title="Yankees" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Yankees</strong></div></a><a href="http://www.cbssports.com/mlb/teams/page/BOS/boston-red-sox" target="_blank" title="Red Sox" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Red Sox</strong></div></a><a href="http://www.cbssports.com/nba/teams/page/BOS/boston-celtics" target="_blank" title="Celtics" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Celtics</strong></div></a><a href="http://www.cbssports.com/nfl/teams/page/NE/new-england-patriots" target="_blank" title="Patriots" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Patriots</strong></div></a><a href="http://www.cbssports.com/nfl/teams/page/NYG/new-york-giants" target="_blank" title="Giants" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Giants</strong></div></a><a href="http://www.cbssports.com/nfl/teams/page/NYJ/new-york-jets" target="_blank" title="Jets" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Jets</strong></div></a><a href="http://www.cbssports.com/nfl/" target="_blank" title="NFL" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a><a href="http://www.cbssports.com/mlb/" target="_blank" title="MLB" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">MLB</strong></div></a><a href="http://www.sportsline.com/" target="_blank" title="Odds" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a><a href="http://www.cbssports.com/nba/" target="_blank" title="NBA" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">NBA</strong></div></a></div>
</div></div><div id="embed-list-5" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Featured Sports</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/2021/09/02/nfc-north-preview-packers-bears-vikings-lions/" title="NFC North Preview: &#039;Got To Give It Up To The Reigning MVP In Aaron Rodgers,&#039; Says CBS Chicago&#039;s Marshall Harris" class="cbs-thumbnail-link item-1630610744" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/09/aaron-rodgers-packers-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">NFC North Preview: &#039;Got To Give It Up To The Reigning MVP In Aaron Rodgers,&#039; Says CBS Chicago&#039;s Marshall Harris</strong><em class="description">The Packers still have all the pieces to make another run at a Super Bowl, especially with Rodgers under center.</em></div></a><a href="https://connecticut.cbslocal.com/2021/09/02/nfc-west-preview-49ers-seahawks-rams-cardinals/" title="NFC West Preview: &#039;The Strongest Division In Football&#039;, CBS San Francisco&#039;s Vern Glenn Has 49ers Coming Out On Top" class="cbs-thumbnail-link item-1630594161" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/09/GettyImages-1337120503.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">NFC West Preview: &#039;The Strongest Division In Football&#039;, CBS San Francisco&#039;s Vern Glenn Has 49ers Coming Out On Top</strong><em class="description">The 49ers were injury plagued throughout the 2020 season but this year Glenn expects them to bounce back in a big way.</em></div></a></div>
</div></div><div id="embed-list-6" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Galleries</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/photo-galleries/2017/11/06/uconn-football-vs-usf-1142017/" title="UConn Football vs USF (11/4/2017)" class="cbs-thumbnail-link item-1509986022 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2017/11/img_02151.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">UConn Football vs USF (11/4/2017)</strong></div></a><a href="https://connecticut.cbslocal.com/photo-galleries/2017/10/23/uconn-football-v-tulsa-102117/" title="UConn Football v. Tulsa [10/21/17]" class="cbs-thumbnail-link item-1508765087 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2017/10/img_8761.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">UConn Football v. Tulsa [10/21/17]</strong></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-3 w-link"><a href="http://connecticut.cbslocal.com/live/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://connecticut.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-7" class="embed-item embed-list enable-type-icons column-count-6 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="http://connecticut.cbslocal.com/category/top-spots">Latest Headlines</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/2021/09/01/college-football-week-1-cbs-tv-schedule/" title="College Football Kicks Off On CBS Sports Network With Five Week 1 Matchups" class="cbs-thumbnail-link item-1630513413" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/09/GettyImages-1229008722.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">College Football Kicks Off On CBS Sports Network With Five Week 1 Matchups</strong><em class="description">College football is back and CBS Sports Network has five games set for opening weekend.</em></div></a><a href="https://connecticut.cbslocal.com/2021/09/01/worlds-strongest-man-cbs/" title="2021 World&#039;s Strongest Man Finale Airing On CBS Saturday, September 4" class="cbs-thumbnail-link item-1630497637" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/07/Brian-Shaw-SBD-Worlds-Strongest-Man-2021-Day-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">2021 World&#039;s Strongest Man Finale Airing On CBS Saturday, September 4</strong><em class="description">Who will take the title of World&#039;s Strongest Man? CBS has coverage of the competition finale this Saturday.</em></div></a><a href="https://connecticut.cbslocal.com/2021/08/30/survivor-41-jeff-probst-nfl-cbs-danny-mccray/" title="&#039;Survivor&#039; 41 Announces Full Cast: Features Former NFL Athlete, Neurosurgeon, College Students" class="cbs-thumbnail-link item-1630343920" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/117528_2104b.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;Survivor&#039; 41 Announces Full Cast: Features Former NFL Athlete, Neurosurgeon, College Students</strong><em class="description">&#039;Survivor&#039; 41 has released the full list of castaways.</em></div></a><a href="https://connecticut.cbslocal.com/2021/08/27/lilly-king-international-swimming-league-interview/" title="&#039;We&#039;re Trying To Bring Swimming To A Broader Audience&#039;: Lilly King On International Swimming League &amp; 2020 Olympics" class="cbs-thumbnail-link item-1630077635" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/GettyImages-11637307041.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;We&#039;re Trying To Bring Swimming To A Broader Audience&#039;: Lilly King On International Swimming League &amp; 2020 Olympics</strong><em class="description">Two-time Olympic gold medalist Lilly King talks with us about the International Swimming League on CBS &amp; CBS Sports Network and her experience at the 2020 Olympics in Tokyo.</em></div></a><a href="https://connecticut.cbslocal.com/2021/08/26/noah-eagle-donte-whitner-cbs-sports-college-football-announcer-analyst-talent/" title="Noah Eagle, Donte Whitner Joins CBS Sports&#039; Growing Roster Of College Football Announcer And Analyst Talent" class="cbs-thumbnail-link item-1630013901" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/najee-harris-alabama-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Noah Eagle, Donte Whitner Joins CBS Sports&#039; Growing Roster Of College Football Announcer And Analyst Talent</strong><em class="description">CBS Sports has extended its talent roster for SEC and Mountain West college football coverage across CBS and CBS Sports Network.</em></div></a><a href="https://connecticut.cbslocal.com/2021/08/24/helene-yorke-the-other-two-interview/" title="&#039;We Kicked It Up A Notch &amp; Lit It On Fire&#039;: Heléne Yorke On Season 2 Of &#039;The Other Two&#039; &amp; Working With Molly Shannon" class="cbs-thumbnail-link item-1629818113" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/GettyImages-1084352014-e1629816091804.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;We Kicked It Up A Notch &amp; Lit It On Fire&#039;: Heléne Yorke On Season 2 Of &#039;The Other Two&#039; &amp; Working With Molly Shannon</strong><em class="description">Heléne Yorke discusses the return of her comedy series &quot;The Other Two&quot; and what it was like to work with Saturday Night Live alumna Molly Shannon.</em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-5 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">More</strong></div></div><div class="submenu"><div class="wrapper"><div id="embed-list-8" class="embed-item embed-list enable-type-icons column-count-5 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="http://connecticut.cbslocal.com/category/travel/">Travel</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2019/08/GettyImages-466663843-4.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://connecticut.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2019/06/gettyimages-598645380-e1537896793352.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a><a href="https://connecticut.cbslocal.com/2019/04/04/final-four-guide-top-10-instagram-worthy-spots-in-minneapolis/" title="Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis" class="cbs-thumbnail-link item-1554411634" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2019/04/igworthy.png?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis</strong><em class="description">With thousands of Final Four fans heading to downtown Minneapolis in the coming days, you better believe the Instagram filters will be flying.</em></div></a><a href="https://connecticut.cbslocal.com/2019/04/04/final-four-guide-best-breweries-minneapolis/" title="Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis" class="cbs-thumbnail-link item-1554411465" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2019/04/187774436.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis</strong><em class="description">Beer-lovers visiting Minneapolis for the Final Four won’t have to go far to find Minnesota’s most beloved beers. Walk in any direction out of U.S. Bank Stadium and you’ll probably find a bar or restaurant serving craft beers from the Twin Cities, the North Shore and other parts of “The Land of 10,000 Beers.&quot; But for hop heads seeking a more direct experience of the state’s brewing culture, there are a few places that need to be on your radar, because they’re well worth the Lyft ride.</em></div></a><a href="https://connecticut.cbslocal.com/2019/04/04/final-four-guide-5-restaurants-near-u-s-bank-stadium/" title="Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium" class="cbs-thumbnail-link item-1554410992" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2019/04/107277389-e1538670804895.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium</strong><em class="description">In Minneapolis for the Final Four and want to try the restaurants where Minneapolitans love to eat? Look no further. Below are some of the most beloved spots in the City of Lakes within walking distance, or a short Lyft ride, from U.S. Bank Stadium.</em></div></a></div>
</div></div><div id="embed-list-9" class="embed-item embed-list enable-type-icons column-count-1 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">More</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="http://connecticut.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-1520875874" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2018/03/CBS.png?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS+</strong></div></a></div>
</div></div></div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://connecticut.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size='[[970,250],[970,66],[728,90]]' data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">NFC North Preview: &#8216;Got To Give It Up To The Reigning MVP In Aaron Rodgers,&#8217; Says CBS Chicago&#8217;s Marshall Harris</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">September 2, 2021 at 3:25 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://connecticut.cbslocal.com/tag/marshall-harris/">Marshall Harris</a>, <a href="https://connecticut.cbslocal.com/tag/nfc-north/">NFC North</a>, <a href="https://connecticut.cbslocal.com/tag/norm-elrod/">Norm Elrod</a></div></div></section><section id="column_block_10" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div class="anvato-iframe-wrapper"><div id="p0"></div></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"5952431","autoplay":true,"titleVisible":false,"accessKey":"EZqvRyKE7qmqDflDPXIw6U7kKZEA0Vx7","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5","customMetadata":{"video":{"cbs_market":"connecticut.cbslocal.com","cbs_platform":"desktop"}}},"comscore":{"clientId":"3000023","c3":"Connecticut.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/CBS.HARTFORD&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}}},"shareLink":"https:\/\/cbsloc.al\/3zIlU0e","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5});});});</script></div></section>
<div class="main-story-wrapper"><p><strong>(<a href="https://chicago.cbslocal.com/2021/09/02/nfc-north-preview-packers-bears-vikings-lions/">CBS Chicago</a>) &#8212;</strong> For awhile this offseason, it seemed like three-time MVP Aaron Rodgers might not remain the Packers quarterback. Rodgers was still fuming over the Jordan Love&#8217;s selection in the 2020 NFL Draft to be his eventual replacement. And word got out before this year&#8217;s draft that he no longer wanted to play in Green Bay. His departure would have opened up the NFC North race to the Chicago Bears and Minnesota Vikings. But it didn&#8217;t play out that way.</p>
<p><strong>Other Division Previews: <a href="/2021/08/27/nfc-east-preview-cowboys-eagles-giants-washington/" target="_blank" rel="nofollow">NFC East</a> | <a href="/2021/09/02/nfc-west-preview-49ers-seahawks-rams-cardinals/" rel="nofollow">NFC West</a> | <a href="/2021/08/31/afc-east-preview-2021-bills-dolphins-patriots-jets/" target="_blank" rel="nofollow">AFC East</a> | <a href="/2021/08/26/afc-west-preview-broncos-chargers-chiefs-raiders/" target="_blank" rel="nofollow">AFC West</a> |</strong></p>
<p>After another Championship season, Rodgers returns under center for the Packers. At least for one more year, Green Bay will be the class of the division. &#8220;We now know who the quarterback in Green Bay is,&#8221; according to CBS Chicago sports anchor Marshall Harris. &#8220;So I&#8217;ve got to give it up to the reigning MVP in Aaron Rodgers and say the Pack. It&#8217;s their division to lose. He&#8217;s got so much to prove right now. He&#8217;s got one of the biggest chips on his shoulder for a guy who&#8217;s an actual MVP. And yet he still seems so angry. You saw his press conference, how he reacted the first time he was able to communicate with the media, how he felt the offseason went. He&#8217;s got something to prove, and I just feel bad for all the other teams in his way and their defenses and the defensive coordinators, specifically.&#8221;</p>
<p>Green Bay still has all the pieces to make another run at a Super Bowl. Rodgers completed 70.7 percent of his passes last season, throwing for 4,299 yards and 48 touchdowns. Davante Adams, who hauled in 115 catches and 18 touchdowns, remains among the league&#8217;s best pass catchers in a deep receiver core. Randall Cobb returns to the fold, and Amari Rodgers comes in out of Clemson. Aaron Jones, who picked up 1,104 yards on 5.5 yards per carry, will anchor the run game.</p>
<p>Although Joe Barry took over for Mike Pettine as defensive coordinator, the already solid defense hasn&#8217;t changed much either in terms of personnel. First-round pick Erik Stokes could take over for Kevin King at cornerback and further solidify a secondary that allowed only 221.2 yards per game passing.</p>
<p>Unlike the Packers, the Bears have plenty of questions at quarterback. Andy Dalton is penciled in as the starter, with first-round pick Justin Fields waiting in the wings. Either will be an improvement over the departed Mitchell Trubisky. Chicago&#8217;s situation at offensive line could also shake up their quarterback situation.</p>
<p>&#8220;It&#8217;s important to have a good offensive line,&#8221; Harris notes. Because that&#8217;s where things start and end with most football teams, and specifically one where the Bears don&#8217;t necessarily have a lot of questions answered there. When you have to go out and sign a 39-year-old to play tackle in Jason Peters, that tells me that you might need a little bit more depth and you might wish people are a little healthier than maybe what they are.&#8221;</p>
<p>Allen Robinson, one of the league&#8217;s better wide receivers, will help whoever is under center. And Marquise Goodwin provides another threat from the wideout position. A strong running game would help, if the Bears had one. David Montgomery ran for 1,070 yards last season, with 4.3 yards per carry. Tarik Cohen is still recovering from a torn ACL and will miss at least the first six weeks of the season. And it&#8217;s unclear how much this offense will be able to do behind the offensive line they&#8217;ve assembled.</p>
<p>&#8220;They could go to the playoffs again,&#8221; Harris suggests. &#8220;And a lot of that is going to depend on their defense and whether their superstars can truly be superstars. I want to see what Khalil Mack does. The Raiders are trying to get him back, but the Bears are like &#8216;nah, we&#8217;re going to hold on to this guy, because we gave up a lot to get him, we&#8217;re trying to do something now.&#8217; I think they&#8217;re trying to do some now. Again, I can&#8217;t tell with the whole Andy Dalton-Justin Fields thing.&#8221;</p>
<p>The Vikings don&#8217;t have an issue at quarterback, at least as they see it. Kirk Cousins put up strong numbers last season, throwing for 4,265 yards and 35 touchdowns. But the team lost five of their first six games and never really challenged in the division. Dalvin Cook was the NFL&#8217;s second leading rusher, with 1,557 yards on 8.2 yards per carry. Wide receiver Justin Jefferson also had a strong rookie season. But tight end <a href="https://minnesota.cbslocal.com/2021/09/01/report-vikings-te-irv-smith-jr-s-season-likely-over-after-knee-surgery/">Irv Smith Jr.</a> will likely miss the season after knee surgery.</p>
<p>The Vikings defense should be better, thanks to health and recent additions. Danielle Hunter returns after neck surgery sidelined him for all of last season. The linebackers room remains strong. And the addition of Patrick Peterson and Bashaud Breeland should bolster the secondary.</p>
<p>The Lions continue to rebuild, now under new head coach Dan Campbell. Longtime quarterback Matthew Stafford was traded to the Los Angeles Rams for Jared Goff. Goff took the Rams to Super Bowl LIII in 2018, but has struggled the last couple years.</p>
<p>&#8220;Jared Goff, a number-one pick now quarterbacking in Detroit&#8230; I&#8217;m interested to see what he has,&#8221; says Harris. &#8220;The man has had some turnover issues the last couple of seasons now. So you take one number-one overall pick in Matthew Stafford, send him out and get another one in Jared Goff. I think Matthew Stafford is better than Jared Goff. I don&#8217;t know what the rebuilding in Detroit is going to look like.&#8221;</p>
<p>The offense Goff will be running is filled with other new players. He&#8217;ll be throwing to new wide Tyrell Williams and Kalif Raymond, neither of whom seem likely to stand out. Jamaal Williams should also get some touches alongside D&#8217;Andre Swift, who remains from last season.</p>
<p>There&#8217;s also plenty of change on the defensive side of the ball. The league&#8217;s worst unit allowed a horrendous 419.8 yards and 32.4 points per game last season. But a lot of those players are gone. Defensive end Michael Brockers, formerly of the Rams, will be an improvement, assuming he&#8217;s healthy and ready to play. Linebacker Alex Anzalone from the New Orleans Saints and safety Dean Marlowe from the Buffalo Bills should be both be a step up as well.</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3zIlU0e"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3zIlU0e"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3zIlU0e"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size='[[1,5],"fluid"]' data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-11"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size='[[300,250],[300,600],[300,1050]]' data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CBSLocal" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/cbslocal" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://connecticut.cbslocal.com/2021/09/02/nfc-north-preview-packers-bears-vikings-lions/" title="NFC North Preview: &#039;Got To Give It Up To The Reigning MVP In Aaron Rodgers,&#039; Says CBS Chicago&#039;s Marshall Harris" class="bump-view" data-bump-view="tp" aria-current="page">
								<img width="55" height="55" src="https://i2.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/09/aaron-rodgers-packers-1.jpg?resize=55%2C55&#038;ssl=1" alt="NFC North Preview: &#039;Got To Give It Up To The Reigning MVP In Aaron Rodgers,&#039; Says CBS Chicago&#039;s Marshall Harris" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/09/02/nfc-north-preview-packers-bears-vikings-lions/" title="NFC North Preview: &#039;Got To Give It Up To The Reigning MVP In Aaron Rodgers,&#039; Says CBS Chicago&#039;s Marshall Harris" class="bump-view" data-bump-view="tp" aria-current="page">NFC North Preview: &#039;Got To Give It Up To The Reigning MVP In Aaron Rodgers,&#039; Says CBS Chicago&#039;s Marshall Harris</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/09/02/stimulus-check-latest-irs-fourth-relief-payment/" title="Fourth Stimulus Check: Will Another Relief Payment Go Out In 2021?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/09/joe-biden-1-1.jpg?resize=55%2C55&#038;ssl=1" alt="Fourth Stimulus Check: Will Another Relief Payment Go Out In 2021?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/09/02/stimulus-check-latest-irs-fourth-relief-payment/" title="Fourth Stimulus Check: Will Another Relief Payment Go Out In 2021?" class="bump-view" data-bump-view="tp">Fourth Stimulus Check: Will Another Relief Payment Go Out In 2021?</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/08/23/stimulus-check-update-fourth-payment-irs-when/" title="Fourth Stimulus Check: Will Another Relief Payment Come This Year?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/joe-biden-1.jpg?resize=55%2C55&#038;ssl=1" alt="Fourth Stimulus Check: Will Another Relief Payment Come This Year?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/08/23/stimulus-check-update-fourth-payment-irs-when/" title="Fourth Stimulus Check: Will Another Relief Payment Come This Year?" class="bump-view" data-bump-view="tp">Fourth Stimulus Check: Will Another Relief Payment Come This Year?</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/08/13/stream-the-wells-fargo-championship/" title="Stream The Wyndham Championship" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/Wyndham_Champ_Local_1200x675.jpg?resize=55%2C55&#038;ssl=1" alt="Stream The Wyndham Championship" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/08/13/stream-the-wells-fargo-championship/" title="Stream The Wyndham Championship" class="bump-view" data-bump-view="tp">Stream The Wyndham Championship</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/08/18/the-northern-trust-preview-trevor-immelman-cbs/" title="The Northern Trust Preview: &#039;Going To Be A Lot Of Fun Because So Many Of The Top Players Are On Form&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/GettyImages-1332731525.jpg?resize=55%2C55&#038;ssl=1" alt="The Northern Trust Preview: &#039;Going To Be A Lot Of Fun Because So Many Of The Top Players Are On Form&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/08/18/the-northern-trust-preview-trevor-immelman-cbs/" title="The Northern Trust Preview: &#039;Going To Be A Lot Of Fun Because So Many Of The Top Players Are On Form&#039;" class="bump-view" data-bump-view="tp">The Northern Trust Preview: &#039;Going To Be A Lot Of Fun Because So Many Of The Top Players Are On Form&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/08/17/baseball-report-fernando-tatis-gerrit-cole/" title="Baseball Report: San Diego Padres Star Fernando Tatis Jr. Returns With A Bang" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/GettyImages-1334361025.jpg?resize=55%2C55&#038;ssl=1" alt="Baseball Report: San Diego Padres Star Fernando Tatis Jr. Returns With A Bang" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/08/17/baseball-report-fernando-tatis-gerrit-cole/" title="Baseball Report: San Diego Padres Star Fernando Tatis Jr. Returns With A Bang" class="bump-view" data-bump-view="tp">Baseball Report: San Diego Padres Star Fernando Tatis Jr. Returns With A Bang</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/08/16/the-price-is-right-50-cbs-bob-barker/" title="&#039;The Price Is Right&#039; Celebrates 50th Season With Weeklong Celebration On CBS" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/115563_0961bc.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;The Price Is Right&#039; Celebrates 50th Season With Weeklong Celebration On CBS" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/08/16/the-price-is-right-50-cbs-bob-barker/" title="&#039;The Price Is Right&#039; Celebrates 50th Season With Weeklong Celebration On CBS" class="bump-view" data-bump-view="tp">&#039;The Price Is Right&#039; Celebrates 50th Season With Weeklong Celebration On CBS</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/08/13/kayla-wood-athletes-unlimited-lacrosse/" title="&#039;It Shows That Anything Is Possible&#039;: Kayla Wood On Athletes Unlimited Lacrosse" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/kayla-wood-11.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;It Shows That Anything Is Possible&#039;: Kayla Wood On Athletes Unlimited Lacrosse" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/08/13/kayla-wood-athletes-unlimited-lacrosse/" title="&#039;It Shows That Anything Is Possible&#039;: Kayla Wood On Athletes Unlimited Lacrosse" class="bump-view" data-bump-view="tp">&#039;It Shows That Anything Is Possible&#039;: Kayla Wood On Athletes Unlimited Lacrosse</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/08/20/jordan-hull-the-l-word-generation-q/" title="&#039;It&#039;s A Big Privilege &amp; I Loved It&#039;: Jordan Hull On Showtime&#039;s &#039;The L Word: Generation Q&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/LWGQ_205_8545_R-e1629464289230.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;It&#039;s A Big Privilege &amp; I Loved It&#039;: Jordan Hull On Showtime&#039;s &#039;The L Word: Generation Q&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/08/20/jordan-hull-the-l-word-generation-q/" title="&#039;It&#039;s A Big Privilege &amp; I Loved It&#039;: Jordan Hull On Showtime&#039;s &#039;The L Word: Generation Q&#039;" class="bump-view" data-bump-view="tp">&#039;It&#039;s A Big Privilege &amp; I Loved It&#039;: Jordan Hull On Showtime&#039;s &#039;The L Word: Generation Q&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2020/07/15/poll-college-students-say-they-wont-party-fall-2020-semester-coronavirus/" title="Poll: 79% Of College Students Say They Wouldn&#039;t Attend Parties This Fall To Prevent Coronavirus Infection" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2020/07/GettyImages-1164951739.jpg?resize=55%2C55&#038;ssl=1" alt="Poll: 79% Of College Students Say They Wouldn&#039;t Attend Parties This Fall To Prevent Coronavirus Infection" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2020/07/15/poll-college-students-say-they-wont-party-fall-2020-semester-coronavirus/" title="Poll: 79% Of College Students Say They Wouldn&#039;t Attend Parties This Fall To Prevent Coronavirus Infection" class="bump-view" data-bump-view="tp">Poll: 79% Of College Students Say They Wouldn&#039;t Attend Parties This Fall To Prevent Coronavirus Infection</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size='[[300,250]]' data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size='[[728,90]]' data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://connecticut.cbslocal.com" class="logo"><img src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2017/10/conn.png" alt="CBS Connecticut" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CBSLocal" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/cbslocal" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			<div id="block-0" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">News</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="http://hartford.cbslocal.com/category/news/" title="Local News" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Local News</strong></div></a><a href="http://connecticut.cbslocal.com/news/national-news/" title="National" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">National</strong></div></a><a href="http://connecticut.cbslocal.com/news/world-news/" title="World" class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">World</strong></div></a><div class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div><div id="block-1" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Sports</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="http://connecticut.cbslocal.com/category/sports/" title="Latest Sports" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Latest Sports</strong></div></a><div class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div><div id="block-2" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Other</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="http://connecticut.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><a href="https://connecticut.cbslocal.com/category/top-spots/" title="Top Spots" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Top Spots</strong></div></a><a href="https://connecticut.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="https://connecticut.cbslocal.com/category/health/" title="Health" class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Health</strong></div></a><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div><div id="block-3" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Corporate</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/site-info/" title="Site Info" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Site Info</strong></div></a><div class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div>		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://connecticut.cbslocal.com" class="logo"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-viacom-logo-white.png" alt="CBS Connecticut" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2021 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=connecticut.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></span>
							</div>

			<div class="right-wrapper">
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-83831" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83831"><a href="https://www.viacomcbsprivacy.com/policy">Privacy Policy</a></li>
<li id="menu-item-356881" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-356881"><a href="https://www.viacomcbsprivacy.com/cookies">Cookies Policy</a></li>
<li id="menu-item-346905" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-346905"><a href="https://www.viacomcbsprivacy.com/donotsell">Do Not Sell My Personal Information</a></li>
<li id="menu-item-83832" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83832"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size='[[1,8]]' data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size='[[1,6]]' data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size='[[1,7]]' data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='screen-css-0' href='https://connecticut.cbslocal.com/_static/??-eJzTLy/QTc7PK0nNK9EvyUjNTS3WT04q1s3JT07M0c/MS84pTQEKpeYmpaYAZYqhTN2czOISPSBXR598/brpRZkpFBuSnJ9bkJgMdox9rq2hmZGlpYGBmYEpAIi9T2A=' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://connecticut.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1629900605g' type='text/css' media='all' />
<script type='text/javascript' src='https://connecticut.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1629145607g'></script>
<script src='https://w3.mp.lura.live/player/prod/v3/scripts/anvload.js?ver=5.8' id='cbs-cbs-anvato-js'></script>
<script src='https://stats.wp.com/e-202135.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.0',blog:'162245988',post:'357305',tz:'-4',srv:'connecticut.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162245988', '357305' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>