<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://connecticut.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="fantasy football, fantasy football 2021, fantasy football breakout players," />
<meta name="keywords" content="sports, fantasy football, ryan mayer" />
<meta property="fb:pages" content="21164911483" />
<title>Fantasy Football 2021 Breakouts: Can Jalen Hurts Put Together A Top 10 Fantasy QB Season? &#8211; CBS Connecticut</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.mp.lura.live' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Connecticut &raquo; Feed" href="https://connecticut.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://connecticut.cbslocal.com/_static/??-eJytj0sOwjAMRC9EsBqpFRvEWfIxJapjR/mI6ze0bFhBJVa2x36jMTyTcsIVuUJ9YMQCzhZF4gxBYEfNv6RS4C5SMZ97e4KfIIwW/c6mjCTGf4cTtTlwgSi+Ud+Yt0Gvx+HtQEXDZsa82XwoqodcqqQDL+0eLVo2gRQFXv6fCqlPXLd/b/E6TPoy6nEa9Ap1k59X' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://connecticut.cbslocal.com/_static/??-eJyNy8EJgDAMQNGFrKEFixdxlhqDCmlaSETcXruAeP28D1d1WMRIDGynTAq4qOOCiUHtZupRtYMvdgjyubakCjVt5Ixy5WQ/3rYQv1FMm57z5GMYhzBEHx4h0Tka' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://connecticut.cbslocal.com/_static/??-eJy1kttugzAMhl9oIW1VtdxMexaTWDStc1Biinj7GbqehjTBxe58+n7HdnSflImBMbDmE3os2jRFUTRAOlHXulC0j7YjyUwFykOAFrM2RSJDwn0l1of+S8gFQ50dQ8L0zqJi9ImAsayEE2RewPx+eTnFzCbeVZ7uivboG7Q3fjIVucLKAAPFduUYMoUzhOr6XN5b3oq0bgS8SJcmQx504YGw8i7MibMMitYBkvSU3q+ObHnArAhbMMMyXHKv/hu0eONy5Rb5cfHRXi8y/3Ae8mWUvdWbSDH/g268Yu6zY5xJ+07dxc7ICeRA2021mTR+AiPz5T+3h119OO7qev8NpoZF6A==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://connecticut.cbslocal.com/_static/??-eJy1UEEOwjAM+xBdYGIIDoi3lK4bLWlalhS031MmDuw2kDhZcWzHCjySMpHEkoBcbLAM5swKo9EIjgzmtlCeIUUcO4dYBUeV5xUsNfpFjoS5d8QQYpuxbHQ7mQuoe/2ZMIu+ZTuMb1gkUsH1gxb7U6dJoIIm3dvhFT0jVLl3lZi+ek6XyYiLxP8oZLFMJFxyT+G42dX7Ztsc1o1/ArD/uj8='></script>
<script src='https://w3.mp.lura.live/player/prod/v3/scripts/anvload.js?ver=5.7.2' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://connecticut.cbslocal.com/_static/??-eJyFjcEKwzAMQ39orWmgZZexb0kdkzo4TpmT9fcbxi67rDchPUlw7AMWraQV6kaZDHC1QQp6AVaUFrqVDHzYyPhNY2Ydk93gX7HzUcrq5ZL8uXhVRqHLzi4tshrkEpr05OAQqX4mvrJPPPNjWtx9dvMyuXQCCsZU0A=='></script>
<link rel="https://api.w.org/" href="https://connecticut.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://connecticut.cbslocal.com/wp-json/wp/v2/posts/357033" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://connecticut.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://connecticut.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://cbsloc.al/3AzEo3i' />
<link rel="alternate" type="application/json+oembed" href="https://connecticut.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fconnecticut.cbslocal.com%2F2021%2F08%2F11%2Ffantasy-football-2021-breakouts-jalen-hurts-dandre-swift-dallas-goedert%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://connecticut.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fconnecticut.cbslocal.com%2F2021%2F08%2F11%2Ffantasy-football-2021-breakouts-jalen-hurts-dandre-swift-dallas-goedert%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		
<meta property="og:title" content="Fantasy Football 2021 Breakouts: Can Jalen Hurts Put Together A Top 10 Fantasy QB Season?" /><meta property="og:image" content="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/GettyImages-1234293349.jpg?w=1500" /><meta property="og:image:secure_url" content="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/GettyImages-1234293349.jpg?w=1500" /><meta property="og:image:width" content="1500" /><meta property="og:image:height" content="1001" /><meta property="og:description" content="The Eagles QB flashed big fantasy upside in his short stint as starter late last season. Now expected to start from Week 1, can he put together a breakout season? Which other players could become new fantasy stars?" /><meta property="og:type" content="article" /><meta property="og:url" content="https://connecticut.cbslocal.com/2021/08/11/fantasy-football-2021-breakouts-jalen-hurts-dandre-swift-dallas-goedert/" /><meta property="article:published_time" content="2021-08-11T08:30:14+00:00" /><meta property="article:suggested-social-copy" content="The Eagles QB flashed big fantasy upside in his short stint as starter late last season. Now expected to start from Week 1, can he put together a breakout season? Which other players could become new fantasy stars?" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Sports" /><meta property="article:publisher" content="https://www.facebook.com/CBSLocal" /><meta property="article:author" content="https://www.facebook.com/CBSLocal" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/GettyImages-1234293349.jpg?w=1500"><meta name="twitter:title" content="Fantasy Football 2021 Breakouts: Can Jalen Hurts Put Together A Top 10 Fantasy QB Season?"/><meta name="twitter:description" content="The Eagles QB flashed big fantasy upside in his short stint as starter late last season. Now expected to start from Week 1, can he put together a breakout season? Which other players could become new fantasy stars?"/><meta name="twitter:site" content="/cbslocal"/>
<link rel="canonical" href="https://connecticut.cbslocal.com/2021/08/11/fantasy-football-2021-breakouts-jalen-hurts-dandre-swift-dallas-goedert/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://connecticut.cbslocal.com/2021/08/11/fantasy-football-2021-breakouts-jalen-hurts-dandre-swift-dallas-goedert/?amp">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/connecticut.cbslocal.com","url":"https:\/\/connecticut.cbslocal.com","name":"CBS Connecticut","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/connecticut.cbslocal.com\/wp-content\/uploads\/sites\/15909867\/2018\/07\/2_cbs_connecticut.png?w=284"}},"url":"https:\/\/connecticut.cbslocal.com\/2021\/08\/11\/fantasy-football-2021-breakouts-jalen-hurts-dandre-swift-dallas-goedert\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/connecticut.cbslocal.com\/2021\/08\/11\/fantasy-football-2021-breakouts-jalen-hurts-dandre-swift-dallas-goedert\/"},"headline":"Fantasy Football 2021 Breakouts: Can Jalen Hurts Put Together A Top 10 Fantasy QB Season?","description":"The Eagles QB flashed big fantasy upside in his short stint as starter late last season. Now expected to start from Week 1, can he put together a breakout season? Which other players could become new fantasy stars?","image":"https:\/\/connecticut.cbslocal.com\/wp-content\/uploads\/sites\/15909867\/2021\/08\/GettyImages-1234293349.jpg?w=1500","keywords":["Sports","Fantasy Football","Ryan Mayer","sports","Fantasy Football 2021 Breakouts: Can Jalen Hurts Put Together A Top 10 Fantasy QB Season?"],"datePublished":"2021-08-11T08:30:14+00:00","dateModified":"2021-08-11T08:30:14+00:00","video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"'Snapchat Dysmorphia': Selfies, Photo Filters Driving People To Plastic Surgery, Doctors Say","description":"Plastic surgeons are sounding the alarm on a disturbing trend.","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/captures\/A0D\/A2F\/A0DA2F76BBF64829BAD50D1EE24A46F9.jpg?Expires=1723334400&KeyName=mcpkey1&Signature=fEL_t_AyQqo7WDr_wxbASEfo2MQ","uploadDate":"2018-08-07","duration":"T24S","contentUrl":"https:\/\/connecticut.cbslocal.com\/video\/3912994-snapchat-dysmorphia-selfies-photo-filters-driving-people-to-plastic-surgery-doctors-say\/","embedUrl":"https:\/\/connecticut.cbslocal.com\/video\/3912994-snapchat-dysmorphia-selfies-photo-filters-driving-people-to-plastic-surgery-doctors-say\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.HARTFORD","sports",["fantasyfootball2021breakoutscanjalenhurtsputtogetheratop10fantasyqbseason","post","article","sports","fantasyfootball","ryanmayer","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("3");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-64" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-64" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"sports;","dimension2":"article"});gtag("config","UA-2438645-64");</script>

		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="The Eagles QB flashed big fantasy upside in his short stint as starter late last season. Now expected to start from Week 1, can he put together a breakout season? Which other players could become new fantasy stars?" />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-357033 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://connecticut.cbslocal.com" id="header-logo"><img src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2018/07/2_cbs_connecticut.png?w=284" alt="CBS Connecticut" /></a>
	
	<nav id="navigation-main" data-item-count="6"><ul class="top"><li class="menu-top-item item-0 section-item"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="http://connecticut.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-1" class="embed-item embed-list column-count-2 block-type-wpmenu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">All News</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="/category/top-headlines/" title="Headlines" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Headlines</strong></div></a><a href="/category/national/" title="National" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">National</strong></div></a><a href="/category/world-news/" title="World" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">World</strong></div></a><a href="/category/technology" title="Technology" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Technology</strong></div></a><a href="http://connecticut.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://connecticut.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><a href="http://connecticut.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a></div>
</div></div><div id="embed-list-2" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Latest Headlines</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/2021/08/10/child-tax-credit-when-next-payment-date/" title="Child Tax Credit: When Will Your Second Payment Arrive?" class="cbs-thumbnail-link item-1628617054" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/irs-building-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Child Tax Credit: When Will Your Second Payment Arrive?</strong><em class="description">The next advance Child Tax Credit payment will be sent out next week, and it will arrive a couple days early.</em></div></a><a href="https://connecticut.cbslocal.com/2021/08/09/child-tax-credit-irs-tools-manage-monthly-payments/" title="Child Tax Credit: IRS Tools To Manage Your Monthly Checks" class="cbs-thumbnail-link item-1628541494" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/child-tax-credit-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Child Tax Credit: IRS Tools To Manage Your Monthly Checks</strong><em class="description">Advance payments for the updated Child Tax Credit will start to arrive again on August 13. These IRS tools will help you manage your money.</em></div></a></div>
</div></div><div id="embed-list-3" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Podcasts</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-4 aspect-ratio-1-1"><a href="http://connecticut.cbslocal.com/audio/mornings-with-ray-dunaway/" title="Ray Dunaway" class="cbs-thumbnail-link item-1476544755" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2016/10/ray-dunaway-250x250.jpg?w=250&#038;h=250&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Ray Dunaway</strong></div></a><a href="http://connecticut.cbslocal.com/audio/sound-off-connecticut-with-jim-vicevich/" title="Sound off Connecticut" class="cbs-thumbnail-link item-1476459631" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2016/10/sound-off-ct-250x250.jpg?w=250&#038;h=250&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Sound off Connecticut</strong></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="http://connecticut.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-4" class="embed-item embed-list column-count-2 block-type-wpmenu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="http://connecticut.cbslocal.com/category/sports/">All Sports</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="http://www.cbssports.com/mlb/teams/page/NYY/new-york-yankees" target="_blank" title="Yankees" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Yankees</strong></div></a><a href="http://www.cbssports.com/mlb/teams/page/BOS/boston-red-sox" target="_blank" title="Red Sox" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Red Sox</strong></div></a><a href="http://www.cbssports.com/nba/teams/page/BOS/boston-celtics" target="_blank" title="Celtics" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Celtics</strong></div></a><a href="http://www.cbssports.com/nfl/teams/page/NE/new-england-patriots" target="_blank" title="Patriots" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Patriots</strong></div></a><a href="http://www.cbssports.com/nfl/teams/page/NYG/new-york-giants" target="_blank" title="Giants" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Giants</strong></div></a><a href="http://www.cbssports.com/nfl/teams/page/NYJ/new-york-jets" target="_blank" title="Jets" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Jets</strong></div></a><a href="http://www.cbssports.com/nfl/" target="_blank" title="NFL" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a><a href="http://www.cbssports.com/mlb/" target="_blank" title="MLB" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">MLB</strong></div></a><a href="http://www.sportsline.com/" target="_blank" title="Odds" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a><a href="http://www.cbssports.com/nba/" target="_blank" title="NBA" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">NBA</strong></div></a></div>
</div></div><div id="embed-list-5" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Featured Sports</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/2021/08/10/sedgefield-country-club-profile-wyndham-championship-donald-ross/" title="Sedgefield Country Club Profile: Wyndham Championship Makes This Classic Donald Ross Course Its Home" class="cbs-thumbnail-link item-1628631963" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2020/08/sedgefield-18th-green-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Sedgefield Country Club Profile: Wyndham Championship Makes This Classic Donald Ross Course Its Home</strong><em class="description">Sedgefield Country Club, in Greensboro, North Carolina, has been home to the Wyndham Championship since 2008.</em></div></a><a href="https://connecticut.cbslocal.com/2021/08/10/baseball-report-mvp-races-shohei-ohtani/" title="Baseball Report: What&#039;s Happening In MLB&#039;s MVP Races?" class="cbs-thumbnail-link item-1628617080" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/shohei-ohtani-angels-1-16.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Baseball Report: What&#039;s Happening In MLB&#039;s MVP Races?</strong><em class="description">This week&#039;s Baseball Report looks at the MVP races, the Field of Dreams game, and the Philadelphia Phillies&#039; emergence as the NL East leader.</em></div></a></div>
</div></div><div id="embed-list-6" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Galleries</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/photo-galleries/2017/11/06/uconn-football-vs-usf-1142017/" title="UConn Football vs USF (11/4/2017)" class="cbs-thumbnail-link item-1509986022 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2017/11/img_02151.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">UConn Football vs USF (11/4/2017)</strong></div></a><a href="https://connecticut.cbslocal.com/photo-galleries/2017/10/23/uconn-football-v-tulsa-102117/" title="UConn Football v. Tulsa [10/21/17]" class="cbs-thumbnail-link item-1508765087 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2017/10/img_8761.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">UConn Football v. Tulsa [10/21/17]</strong></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-3 w-link"><a href="http://connecticut.cbslocal.com/live/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://connecticut.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-7" class="embed-item embed-list enable-type-icons column-count-6 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="http://connecticut.cbslocal.com/category/top-spots">Latest Headlines</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/2021/08/10/stargirl-dc-universe-cw-brec-bassinger/" title="Brec Bassinger On Becoming A Super Hero And Season 2 Of &#039;DC&#039;s Stargirl&#039;: &#039;Truly Honored&#039;" class="cbs-thumbnail-link item-1628621611" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Brec Bassinger On Becoming A Super Hero And Season 2 Of &#039;DC&#039;s Stargirl&#039;: &#039;Truly Honored&#039;</strong><em class="description">&#039;Stargirl&#039;s Brec Bassinger discusses her excitement for season 2 coming to The CW.</em></div></a><a href="https://connecticut.cbslocal.com/2021/08/09/uefa-super-cup-2021-chelsea-villareal-how-to-watch/" title="UEFA Super Cup 2021: How To Watch Chelsea Vs. Villareal" class="cbs-thumbnail-link item-1628526974" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/GettyImages-1333167501.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">UEFA Super Cup 2021: How To Watch Chelsea Vs. Villareal</strong><em class="description">The two champions of Europe in the Champions and Europa League meet this week and CBS Sports has you covered.</em></div></a><a href="https://connecticut.cbslocal.com/2021/08/09/piglet-dr-melissa-shapiro-interview/" title="&#039;You Never Know What Will Come From A Little Yes&#039;: Veterinarian Dr. Melissa Shapiro Discusses Book On Deaf &amp; Blind Dog Piglet" class="cbs-thumbnail-link item-1628526908" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/piglet.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;You Never Know What Will Come From A Little Yes&#039;: Veterinarian Dr. Melissa Shapiro Discusses Book On Deaf &amp; Blind Dog Piglet</strong><em class="description">The author and veterinarian talks with us about the incredible journey of her deaf, blind and pink puppy named Piglet.</em></div></a><a href="https://connecticut.cbslocal.com/2021/08/08/leo-sheng-the-l-word-generation-q/" title="&#039;It&#039;s Huge To Tell A Story Of A Trans Man Of Color&#039;: Leo Sheng On Season 2 Of Showtime&#039;s &#039;The L Word: Generation Q&#039;" class="cbs-thumbnail-link item-1628467226" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/LWGQ_202_1681_R-e1628265628711.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;It&#039;s Huge To Tell A Story Of A Trans Man Of Color&#039;: Leo Sheng On Season 2 Of Showtime&#039;s &#039;The L Word: Generation Q&#039;</strong><em class="description">The transgender actor previews season two of the hit Showtime series and the importance of representing everyone in the LGBTQ+ community.</em></div></a><a href="https://connecticut.cbslocal.com/2021/08/08/katherine-moennig-leisha-hailey-l-word-generation-q/" title="&#039;A Lot Of Relationships Develop That You Weren&#039;t Expecting&#039;: Katherine Moennig &amp; Leisha Hailey On Season 2 Of &#039; The L Word: Generation Q&#039;" class="cbs-thumbnail-link item-1628466305" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/LWGQ_201_5178_R-e1628179659166.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;A Lot Of Relationships Develop That You Weren&#039;t Expecting&#039;: Katherine Moennig &amp; Leisha Hailey On Season 2 Of &#039; The L Word: Generation Q&#039;</strong><em class="description">The stars of &quot;The L Word: Generation Q&quot; preview season two of the hit series on Showtime and explain how this show has impacted the LGBTQ+ community.</em></div></a><a href="https://connecticut.cbslocal.com/2021/08/05/south-park-trey-parker-matt-stone-movie-paramount-plus-comedy-central/" title="&#039;South Park&#039; Brings 14 New Movies To Paramount+, 3 More Seasons On Comedy Central" class="cbs-thumbnail-link item-1628188035" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/ParamountFeat.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;South Park&#039; Brings 14 New Movies To Paramount+, 3 More Seasons On Comedy Central</strong><em class="description">&#039;South Park&#039; co-creators Trey Parker and Matt Stone have agreed to a new deal with MTV Entertainment Studios extending the series on Comedy Central through 2027 for an unprecedented 30th season.</em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-5 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">More</strong></div></div><div class="submenu"><div class="wrapper"><div id="embed-list-8" class="embed-item embed-list enable-type-icons column-count-5 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="http://connecticut.cbslocal.com/category/travel/">Travel</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2019/08/GettyImages-466663843-4.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://connecticut.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2019/06/gettyimages-598645380-e1537896793352.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a><a href="https://connecticut.cbslocal.com/2019/04/04/final-four-guide-top-10-instagram-worthy-spots-in-minneapolis/" title="Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis" class="cbs-thumbnail-link item-1554411634" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2019/04/igworthy.png?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis</strong><em class="description">With thousands of Final Four fans heading to downtown Minneapolis in the coming days, you better believe the Instagram filters will be flying.</em></div></a><a href="https://connecticut.cbslocal.com/2019/04/04/final-four-guide-best-breweries-minneapolis/" title="Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis" class="cbs-thumbnail-link item-1554411465" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2019/04/187774436.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis</strong><em class="description">Beer-lovers visiting Minneapolis for the Final Four won’t have to go far to find Minnesota’s most beloved beers. Walk in any direction out of U.S. Bank Stadium and you’ll probably find a bar or restaurant serving craft beers from the Twin Cities, the North Shore and other parts of “The Land of 10,000 Beers.&quot; But for hop heads seeking a more direct experience of the state’s brewing culture, there are a few places that need to be on your radar, because they’re well worth the Lyft ride.</em></div></a><a href="https://connecticut.cbslocal.com/2019/04/04/final-four-guide-5-restaurants-near-u-s-bank-stadium/" title="Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium" class="cbs-thumbnail-link item-1554410992" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2019/04/107277389-e1538670804895.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium</strong><em class="description">In Minneapolis for the Final Four and want to try the restaurants where Minneapolitans love to eat? Look no further. Below are some of the most beloved spots in the City of Lakes within walking distance, or a short Lyft ride, from U.S. Bank Stadium.</em></div></a></div>
</div></div><div id="embed-list-9" class="embed-item embed-list enable-type-icons column-count-1 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">More</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="http://connecticut.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-1520875874" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2018/03/CBS.png?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS+</strong></div></a></div>
</div></div></div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://connecticut.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size='[[970,250],[970,66],[728,90]]' data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">Fantasy Football 2021 Breakouts: Can Jalen Hurts Put Together A Top 10 Fantasy QB Season?</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">August 11, 2021 at 8:30 am</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://connecticut.cbslocal.com/tag/fantasy-football/">Fantasy Football</a>, <a href="https://connecticut.cbslocal.com/tag/ryan-mayer/">Ryan Mayer</a></div></div></section><section id="column_block_10" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div class="anvato-iframe-wrapper"><div id="p0"></div></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"5879645","autoplay":true,"titleVisible":false,"accessKey":"EZqvRyKE7qmqDflDPXIw6U7kKZEA0Vx7","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5","customMetadata":{"video":{"cbs_market":"connecticut.cbslocal.com","cbs_platform":"desktop"}}},"comscore":{"clientId":"3000023","c3":"Connecticut.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/CBS.HARTFORD&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}}},"shareLink":"https:\/\/cbsloc.al\/3AzEo3i","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5});});});</script></div></section>
<div class="main-story-wrapper"><p><strong>(CBS Local)- </strong>One of the biggest questions that fantasy football owners ask themselves before their league draft is which players could be due for a breakout year? Two years ago, Ravens&#8217; QB Lamar Jackson was coming off a solid rookie season, but then he erupted into a fantasy monster. Last year, rookie running back Jonathan Taylor and wide receiver Justin Jefferson made immediate impacts, totaling 215 and 186 fantasy points respectively.</p>
<p>For breakout players, there is always a mix of rookies and second-year players who establish themselves as the stars of the fantasy season. With that in mind, we took a look through the CBSSports.com fantasy football experts lists of potential breakout players to identify two at each position to watch. If you want to check out <a href="https://www.cbssports.com/fantasy/football/news/fantasy-football-2021-jamey-eisenbergs-breakouts-2-0-lean-heavily-on-budding-year-two-stars-at-all-positions/" target="_blank" rel="noopener">Jamey Eisenberg</a>, Dave Richard, and Heath Cummings&#8217; full explanations, <a href="https://www.cbssports.com/fantasy/football/draft-prep/" target="_blank" rel="noopener">CBS Sports&#8217; fantasy football hub</a> has you covered.</p>
<p><strong>Positional Top 10 Rankings: <a href="/2021/08/03/fantasy-football-rankings-2021-quarterbacks/" target="_blank" rel="nofollow">Top 10 QBs</a> | <a href="/fantasy-football-2021-rb-rankings-christian-mccaffrey-dalvin-cook/" target="_blank" rel="nofollow">Top 10 RBs</a> | <a href="/fantasy-football-2021-wide-receiver-rankings-tyreek-hill-davante-adams-battle-for-top-spot/" target="_blank" rel="nofollow">Top 10 WRs</a> | <a href="/fantasy-football-2021-tight-end-rankings-travis-kelce-darren-waller-george-kittle/" target="_blank" rel="nofollow">Top 10 TEs</a> | <a href="/2021/08/09/fantasy-football-2021-sleepers/" target="_blank" rel="nofollow">Sleepers</a><br />
</strong></p>
<h2>Quarterbacks</h2>
<p><strong>Jalen Hurts, Philadelphia Eagles</strong></p>
<p>Hurts showed up on our Top 10 QBs rankings list for fantasy this season, so it&#8217;s not really a surprise that Jamey and Dave have him listed as a breakout player as well. One of the biggest reasons is, of course, Hurts&#8217; ability to make plays with his legs in addition to his arm.</p>
<p>&#8220;Hurts looked the part of Fantasy star last year, when he scored 20, 43 and 19 Fantasy points in his first three starts against New Orleans, Arizona and Dallas, and he was on pace for 4,517 passing yards, 27 touchdowns and 11 interceptions, as well as 1,269 rushing yards and five touchdowns over 16 games. That&#8217;s likely not realistic, but his rushing potential gives him a huge advantage over most quarterbacks,&#8221; Eisenberg writes.</p>
<p>The projections have him throwing for 3,625 yards and 23 touchdowns while adding another 794 and five TDs on the ground for a strong 19.6 fantasy points per game average. At an ADP of 82 at the moment, Hurts is lasting into the sixth round in early drafts.</p>
<p><strong>Joe Burrow, Cincinnati Bengals</strong></p>
<p>Burrow was on his way to being a breakout fantasy star last year before getting injured in Week 11. He averaged 20 fantasy points per game last season, and the Bengals added his former teammate, J&#8217;Marr Chase with their first-round pick to upgrade his receiving corps.</p>
<p>In addition to expected improvement now that he&#8217;s seen NFL action and learned the pace of the game, Cummings points out that the Bengals were one of the most pass-happy offenses last season, averaging 40 attempts per game with Burrow under center.</p>
<p>There&#8217;s no reason to expect that to change with Chase in the fold. With a projection of 332 total points (19.5 per game) and an ADP of 106 at the time of writing (eighth round in 12-team leagues), Burrow can establish himself as a viable starting fantasy option this season.</p>
<h2>Running Backs</h2>
<p><strong>Antonio Gibson, Washington Football Team</strong></p>
<p>Gibson showed his ability to be a factor in fantasy last season, when he totaled 165 points (11.8 per game) in just 14 games, 10 starts for Washington. His value as a pass catcher is what makes him plenty exciting, considering he snagged 36 of 44 targets last season.</p>
<p>With Curtis Samuel added to the mix on offense and Ryan Fitzpatrick under center, the thought is that Gibson should have more room to operate than he did at times last season.</p>
<p><strong>D&#8217;Andre Swift, Detroit Lions</strong></p>
<p>With Kerryon Johnson now in Philadelphia and Adrian Peterson no longer on the roster, Swift becomes the top back in Detroit. The Lions added Jamaal Williams from Green Bay in free agency, but all expectations indicate that Swift will get the majority of the workload.</p>
<p>The Lions added to their offensive line by bringing in rookie tackle Penei Sewell with their first-round pick and, as Cummings notes, Detroit&#8217;s offense is likely to be running back friendly.</p>
<p>&#8220;Anthony Lynn&#8217;s offenses have historically been very running back friendly, with the position garnering more than 30 touches per game most years,&#8221; Cummings writes.</p>
<p>Swift is a factor in the passing game as well with 46 receptions for 357 yards last season, and that was with Detroit still having Kenny Golladay and Marvin Jones (both gone) on the roster. He&#8217;s getting drafted early (ADP of 17) but he&#8217;s just outside the Top 10 running backs in projections so, if you find yourself in the mid-second round looking to add another back, Swift is a solid choice.</p>
<h2>Wide Receivers</h2>
<p><strong>CeeDee Lamb, Dallas Cowboys</strong></p>
<p>This is pretty simple. Lamb fell just short of 1,000 yards receiving last season (935) and was just outside the Top 20 of fantasy receivers, despite having a mix of Andy Dalton, Ben DiNucci and Garrett Gilbert throwing to him after Dak Prescott went down.</p>
<p>Prescott is back healthy and Lamb enters Year 2 as part of a dangerous Cowboys offense. As Eisenberg points out, Lamb was over 16.2 PPR points in every game with Prescott last season, seeing eight targets per game. No reason to believe that won&#8217;t continue as the two build more chemistry together in a full year.</p>
<p><strong>Ja&#8217;marr Chase, Cincinnati Bengals</strong></p>
<p>There have been reports recently of <a href="https://theathletic.com/2759562/2021/08/09/bengals-stock-report-10-risers-and-fallers-through-10-practices/?source=emp_shared_article" target="_blank" rel="nofollow">Chase struggling in training camp</a> which is exactly the opposite kind of news that potential fantasy owners want to hear. But, even with the struggles, there will be opportunity available to Chase in the Bengals offense.</p>
<p>As mentioned above, the team was one of the most pass-happy in the league last season with Joe Burrow attempting 40 throws per game. Three receivers, Tyler Boyd, Tee Higgins and A.J. Green topped 100 targets as a result. Green is now in Arizona and Chase steps in to work with his former LSU teammate. At the very least, you&#8217;d expect him to get as many targets as Green did (104).</p>
<p>Projections have him at 111 targets over the course of the season and totaling 144 fantasy points in non-ppr leagues (223.3 in PPR).</p>
<h2>Tight Ends</h2>
<p><strong>Dallas Goedert, Philadelphia Eagles</strong></p>
<p>Goedert appeared in two of the three breakouts pieces thus far, and he&#8217;s expected to be the starting tight end for the Eagles when they line up in Week 1. The only uncertainty here is whether Zach Ertz will still be with the team. If he is, the ceiling for Goedert likely lowers some, as Ertz is still a viable tight end. But, if Ertz is gone, Goedert showed what he can do as the main focus at tight end last season.</p>
<p>&#8220;Goedert played four games in 2020 with Ertz injured, and Goedert scored at least 18 PPR points in two of those outings. And in two full games with Hurts he saw 14 targets,&#8221; writes Eisenberg.</p>
<p>The Eagles tight end made an appearance on the Top 10 tight ends ranking as well and is projected to finish inside the Top 10 this season.</p>
<p><strong>T.J. Hockenson, Detroit Lions</strong></p>
<p>As alluded to in D&#8217;Andre Swift&#8217;s notes above, the Lions passing game doesn&#8217;t have a ton of proven options in the receiver corps. That&#8217;s what makes Hockenson very appealing.</p>
<p>He was targeted 101 times last season and hauled in 67 receptions for 723 yards and six touchdowns. With an unsettled receiving corps after the departures of Kenny Golladay and Marvin Jones in free agency, Hockenson may be the best available option for new starting QB Jared Goff.</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3AzEo3i"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3AzEo3i"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3AzEo3i"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size='[[1,5],"fluid"]' data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-11"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size='[[300,250],[300,600],[300,1050]]' data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CBSLocal" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/cbslocal" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://connecticut.cbslocal.com/2021/08/09/stimulus-check-update-fourth-payment-irs-when/" title="Fourth Stimulus Check: Is Another Relief Payment On The Horizon?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/08/joe-biden-8-1.jpg?resize=55%2C55&#038;ssl=1" alt="Fourth Stimulus Check: Is Another Relief Payment On The Horizon?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/08/09/stimulus-check-update-fourth-payment-irs-when/" title="Fourth Stimulus Check: Is Another Relief Payment On The Horizon?" class="bump-view" data-bump-view="tp">Fourth Stimulus Check: Is Another Relief Payment On The Horizon?</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2020/12/10/amazon-driver-stealing-package-elk-grove/" title="VIDEO: Christmas Package Allegedly Swiped Off Family&#039;s Porch -- By Amazon Driver!" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2020/12/amazon-stealing.jpg?resize=55%2C55&#038;ssl=1" alt="VIDEO: Christmas Package Allegedly Swiped Off Family&#039;s Porch -- By Amazon Driver!" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2020/12/10/amazon-driver-stealing-package-elk-grove/" title="VIDEO: Christmas Package Allegedly Swiped Off Family&#039;s Porch -- By Amazon Driver!" class="bump-view" data-bump-view="tp">VIDEO: Christmas Package Allegedly Swiped Off Family&#039;s Porch -- By Amazon Driver!</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2020/12/10/okee-dokee-brothers-grammy-nomination-best-childrens-album-all-white-nominees/" title="The Okee Dokee Brothers Decline Grammy Nomination For Best Children’s Album Due To &#039;All White&#039; Nominees" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2020/12/GettyImages-1156775147-2.jpg?resize=55%2C55&#038;ssl=1" alt="The Okee Dokee Brothers Decline Grammy Nomination For Best Children’s Album Due To &#039;All White&#039; Nominees" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2020/12/10/okee-dokee-brothers-grammy-nomination-best-childrens-album-all-white-nominees/" title="The Okee Dokee Brothers Decline Grammy Nomination For Best Children’s Album Due To &#039;All White&#039; Nominees" class="bump-view" data-bump-view="tp">The Okee Dokee Brothers Decline Grammy Nomination For Best Children’s Album Due To &#039;All White&#039; Nominees</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/07/26/major-league-rugby-cbs-how-to-watch/" title="Major League Rugby Championship Featuring Rugby ATL Against L.A. Giltinis On CBS Sunday August 1" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/07/GettyImages-1329436400.jpg?resize=55%2C55&#038;ssl=1" alt="Major League Rugby Championship Featuring Rugby ATL Against L.A. Giltinis On CBS Sunday August 1" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/07/26/major-league-rugby-cbs-how-to-watch/" title="Major League Rugby Championship Featuring Rugby ATL Against L.A. Giltinis On CBS Sunday August 1" class="bump-view" data-bump-view="tp">Major League Rugby Championship Featuring Rugby ATL Against L.A. Giltinis On CBS Sunday August 1</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/07/28/sam-strauss-the-end-interview/" title="&#039;It Is About Family &amp; Finding The Fun In Aging&#039;: Writer &amp; Producer Sam Strauss On Showtime&#039;s &#039;The End&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/07/TheEnd_107_0025_R-e1627500637714.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;It Is About Family &amp; Finding The Fun In Aging&#039;: Writer &amp; Producer Sam Strauss On Showtime&#039;s &#039;The End&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/07/28/sam-strauss-the-end-interview/" title="&#039;It Is About Family &amp; Finding The Fun In Aging&#039;: Writer &amp; Producer Sam Strauss On Showtime&#039;s &#039;The End&#039;" class="bump-view" data-bump-view="tp">&#039;It Is About Family &amp; Finding The Fun In Aging&#039;: Writer &amp; Producer Sam Strauss On Showtime&#039;s &#039;The End&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/07/26/olympics-2021-uswnt-australia-things-to-know/" title="Olympics 2021: USWNT Vs. Australia, 5 Things Fans Should Know" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/07/GettyImages-1330397778.jpg?resize=55%2C55&#038;ssl=1" alt="Olympics 2021: USWNT Vs. Australia, 5 Things Fans Should Know" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/07/26/olympics-2021-uswnt-australia-things-to-know/" title="Olympics 2021: USWNT Vs. Australia, 5 Things Fans Should Know" class="bump-view" data-bump-view="tp">Olympics 2021: USWNT Vs. Australia, 5 Things Fans Should Know</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/07/28/curtiss-cook-the-chi-season-four-interview/" title="&#039;I Got Chills&#039;: Curtiss Cook On Season 4 Of Showtime&#039;s &#039;The Chi&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/07/TheChi_405_3194_R-e1627472836471.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;I Got Chills&#039;: Curtiss Cook On Season 4 Of Showtime&#039;s &#039;The Chi&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/07/28/curtiss-cook-the-chi-season-four-interview/" title="&#039;I Got Chills&#039;: Curtiss Cook On Season 4 Of Showtime&#039;s &#039;The Chi&#039;" class="bump-view" data-bump-view="tp">&#039;I Got Chills&#039;: Curtiss Cook On Season 4 Of Showtime&#039;s &#039;The Chi&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2015/03/03/expert-men-have-terrific-insecurities-about-penis-size-want-to-be-sexual-provider/" title="Expert: Men Have &#039;Terrific Insecurities&#039; About Penis Size, Want To Be &#039;Sexual Provider&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2014/09/doctor-generic-health-getty-joe-raedle.jpg?resize=55%2C55&#038;ssl=1" alt="Expert: Men Have &#039;Terrific Insecurities&#039; About Penis Size, Want To Be &#039;Sexual Provider&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2015/03/03/expert-men-have-terrific-insecurities-about-penis-size-want-to-be-sexual-provider/" title="Expert: Men Have &#039;Terrific Insecurities&#039; About Penis Size, Want To Be &#039;Sexual Provider&#039;" class="bump-view" data-bump-view="tp">Expert: Men Have &#039;Terrific Insecurities&#039; About Penis Size, Want To Be &#039;Sexual Provider&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/07/28/olympics-2021-uswnt-netherlands-quarterfinals/" title="Olympics 2021: USWNT Faces Netherlands In Quarterfinals, Things To Know About Rematch Of 2019 World Cup Final" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/07/GettyImages-1330887363-16.jpg?resize=55%2C55&#038;ssl=1" alt="Olympics 2021: USWNT Faces Netherlands In Quarterfinals, Things To Know About Rematch Of 2019 World Cup Final" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/07/28/olympics-2021-uswnt-netherlands-quarterfinals/" title="Olympics 2021: USWNT Faces Netherlands In Quarterfinals, Things To Know About Rematch Of 2019 World Cup Final" class="bump-view" data-bump-view="tp">Olympics 2021: USWNT Faces Netherlands In Quarterfinals, Things To Know About Rematch Of 2019 World Cup Final</a>
							</div>
													</li>
										<li>
						<a href="https://connecticut.cbslocal.com/2021/07/28/stephen-king-billy-summers-new-simon-and-schuster/" title="WATCH: Stephen King Reads From His New Book ‘Billy Summers’" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2021/07/SK1.jpg?resize=55%2C55&#038;ssl=1" alt="WATCH: Stephen King Reads From His New Book ‘Billy Summers’" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://connecticut.cbslocal.com/2021/07/28/stephen-king-billy-summers-new-simon-and-schuster/" title="WATCH: Stephen King Reads From His New Book ‘Billy Summers’" class="bump-view" data-bump-view="tp">WATCH: Stephen King Reads From His New Book ‘Billy Summers’</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size='[[300,250]]' data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size='[[728,90]]' data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://connecticut.cbslocal.com" class="logo"><img src="https://connecticut.cbslocal.com/wp-content/uploads/sites/15909867/2017/10/conn.png" alt="CBS Connecticut" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CBSLocal" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/cbslocal" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			<div id="block-0" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">News</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="http://hartford.cbslocal.com/category/news/" title="Local News" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Local News</strong></div></a><a href="http://connecticut.cbslocal.com/news/national-news/" title="National" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">National</strong></div></a><a href="http://connecticut.cbslocal.com/news/world-news/" title="World" class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">World</strong></div></a><div class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div><div id="block-1" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Sports</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="http://connecticut.cbslocal.com/category/sports/" title="Latest Sports" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Latest Sports</strong></div></a><div class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div><div id="block-2" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Other</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="http://connecticut.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><a href="https://connecticut.cbslocal.com/category/top-spots/" title="Top Spots" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Top Spots</strong></div></a><a href="https://connecticut.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="https://connecticut.cbslocal.com/category/health/" title="Health" class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Health</strong></div></a><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div><div id="block-3" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Corporate</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="https://connecticut.cbslocal.com/site-info/" title="Site Info" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Site Info</strong></div></a><div class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div>		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://connecticut.cbslocal.com" class="logo"><img src="https://connecticut.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-viacom-logo-white.png" alt="CBS Connecticut" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2021 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=connecticut.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></span>
							</div>

			<div class="right-wrapper">
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-83831" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83831"><a href="https://www.viacomcbsprivacy.com/policy">Privacy Policy</a></li>
<li id="menu-item-356881" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-356881"><a href="https://www.viacomcbsprivacy.com/cookies">Cookies Policy</a></li>
<li id="menu-item-346905" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-346905"><a href="https://www.viacomcbsprivacy.com/donotsell">Do Not Sell My Personal Information</a></li>
<li id="menu-item-83832" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83832"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size='[[1,8]]' data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size='[[1,6]]' data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size='[[1,7]]' data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='screen-css-0' href='https://connecticut.cbslocal.com/_static/??-eJzTLy/QTc7PK0nNK9EvyUjNTS3WT04q1s3JT07M0c/MS84pTQEKpeYmpaYAZYqhTN2czOISPSBXR598/brpRZkpFBuSnJ9bkJgMdox9rq2hmZGFqZGpmaERAIi7T2A=' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://connecticut.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1628525612g' type='text/css' media='all' />
<script type='text/javascript' src='https://connecticut.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1628545906g'></script>
<script src='https://w3.mp.lura.live/player/prod/v3/scripts/anvload.js?ver=5.7.2' id='cbs-cbs-anvato-js'></script>
<script src='https://stats.wp.com/e-202132.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.0',blog:'162245988',post:'357033',tz:'-4',srv:'connecticut.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162245988', '357033' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>